Uploaded image for project: 'ZK JSP'
  1. ZK JSP
  2. ZKJSP-15

JSP portlet using ZK JSP tags does not work on IBM Websphere Portal v 8.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.0
    • Labels:
    • Environment:

      ZK JSP 2.3 ZK 6.5.4 on IBM Websphere Portal server v 8.0

      Description

      Currently there is no standard docs for deploying ZK JSP on a Portal server. Making a JSP Portlet and including ZK JSP 2.3 with it the portal does not start even though the war file is deployed and started correctly.

      Steps tried so far.
      1. Download zkJspDemo for 2.3 version
      2. Add portlet.xml under WEB-INF
      3. Use a GenericPortlet impl for rendering Portlet instead of UpdateLayoutPortlet of ZK
      4. Export war and deploy to Websphere portal server v8.0
      5. War is deployed but portlet status is stopped (No error is shown or no log entry) (Ashish: Usually it means config issue but not sure)

        Attachments

        1. HelloZulJsp.war
          3.94 MB
        2. HelloZulJsp.zip
          32 kB
        3. zkjspDemoPortlet_src.zip
          996 kB

          Activity

            People

            Assignee:
            hawk hawk
            Reporter:
            ashishd ashishd
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: