Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 3.0.2
    • Security Level: Jimmy
    • Labels:

      Description

      Steps to Reproduce

      1. run the attached example charts-datetime-with-model.zul
      2. click the button to add another value dynamically

      Current Result

      1. the datetime axis is displayed using milliseconds instead of the correct dates values and also the different intervals between the dates are not reflected

      2. the x-axis gets scaled completely incorrect

      Expected Result

      correctly rendered datetime axis and correct intervals between the value points
      (same as using the workaround - setting the model after adding the data values)

      Debug Info

      this happens when setting the model to the chart after adding the values

      Workaround

      assign the model before adding values to it
      (commented out in the attached example)

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            rudyhuang rudyhuang
            Reporter:
            cor3000 cor3000
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 4 hours
              4h