Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4205

inconsistent parameter names (dead/obsolete code?)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 5.0.0, 8.6.0.1
    • Fix Version/s: 8.6.2
    • Component/s: ZK Update Engine
    • Security Level: Jimmy
    • Labels:
    • gh.sprint.customfield.default.name:
      ZK 8.6.2 S1

      Description

      Since ZK 5 the zkau parameter names convention has changed from '.' to '_'
      https://github.com/zkoss/zk/commit/c225c6b40e8ce3ca00433cee87d7183c1fae5aab

      It looks like one occasion was forgotten and leads to a null value since then:
      https://github.com/zkoss/zk/blob/v8.6.0.1/zk/src/org/zkoss/zk/au/http/DHtmlUpdateServlet.java#L746

      As a consequence in the only place where the getFirstCommand method is called will always lead to calling recover()
      https://github.com/zkoss/zk/blob/v8.6.0.1/zk/src/org/zkoss/zk/au/http/DHtmlUpdateServlet.java#L548-L550

      Either this code is obsolete or should be fixed to use the correct parameter name convention.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rudyhuang rudyhuang
                Reporter:
                cor3000 cor3000
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours
                  4h
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 4 hours
                  4h