Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-1398

Set open attribute to the tree templeate is not work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: 6.0.2, 6.5.0
    • Fix Version/s: None
    • Component/s: Components
    • Labels:
      None

      Description

      <zk>
      	<zscript><![CDATA[
      		import org.zkoss.zul.DefaultTreeModel;
      		import org.zkoss.zul.DefaultTreeNode;
      		
      		DefaultTreeNode root = new DefaultTreeNode(null,
      		    new DefaultTreeNode[] {
      		      new DefaultTreeNode("item a"),
      		      new DefaultTreeNode("item b"),
      		      new DefaultTreeNode("item c",
      		        new DefaultTreeNode[] {
      	    		  new DefaultTreeNode("item c1"),
      	              new DefaultTreeNode("item c2")
      		        })
      		      }
      		  );
      		DefaultTreeModel model = new DefaultTreeModel(root);
      	]]></zscript>
      	
      	<tree model="${model}" width="150px">
      		<template name="model">
      	        <treeitem label="${each}" open="true"/>
      	    </template>
      	</tree>
      	
      </zk>
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              vincentjian vincentjian
              Reporter:
              jimmyshiau jimmyshiau
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: