Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.5.0 RC
    • Fix Version/s: 3.5.0
    • Component/s: ZSS Component
    • Labels:
    • Environment:

      Win 7 x64, server tomcat 7

      Description

      When the attachment file (of this issue) is load with :
      <spreadsheet src="POC_Sopra.xlsx" width="1000px" height="1000px" showSheetbar="true" showToolbar="true"
      showFormulabar="true" maxVisibleRows="200" maxVisibleColumns="40"/>

      It's trigger this error :

      HTTP ERROR 500

      Problem accessing /tab_tableur.zul. Reason:

      Server Error

      Caused by:

      org.zkoss.zss.model.InvalidModelOpException: name '_dif6' is dpulicated
      at org.zkoss.zss.model.impl.BookImpl.checkLegalNameName(BookImpl.java:277)
      at org.zkoss.zss.model.impl.BookImpl.createName(BookImpl.java:574)
      at org.zkoss.zss.model.impl.BookImpl.createName(BookImpl.java:570)
      at org.zkoss.zss.range.impl.imexp.AbstractExcelImporter.importNamedRange(AbstractExcelImporter.java:162)
      at org.zkoss.zss.range.impl.imexp.AbstractExcelImporter.imports(AbstractExcelImporter.java:97)
      at org.zkoss.zss.range.impl.imexp.ExcelImportAdapter.imports(ExcelImportAdapter.java:40)
      at org.zkoss.zss.range.impl.imexp.AbstractImporter.imports(AbstractImporter.java:54)
      at org.zkoss.zss.ui.Spreadsheet.getSBook(Spreadsheet.java:606)
      at org.zkoss.zss.ui.Spreadsheet.getSelectedSSheet(Spreadsheet.java:800)
      at org.zkoss.zss.ui.Spreadsheet.doInvalidate(Spreadsheet.java:4376)
      at org.zkoss.zss.ui.Spreadsheet.invalidate(Spreadsheet.java:3752)
      at org.zkoss.zss.ui.Spreadsheet.setSrc(Spreadsheet.java:840)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at org.zkoss.zk.ui.metainfo.Property.assign0(Property.java:284)
      at org.zkoss.zk.ui.metainfo.Property.assign(Property.java:169)
      at org.zkoss.zk.ui.metainfo.ComponentInfo.applyProperties(ComponentInfo.java:729)
      at org.zkoss.zk.ui.impl.AbstractUiFactory.newComponent(AbstractUiFactory.java:106)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreateChild0(UiEngineImpl.java:857)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreateChild(UiEngineImpl.java:826)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreate0(UiEngineImpl.java:735)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreate(UiEngineImpl.java:699)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreateChild0(UiEngineImpl.java:872)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreateChild(UiEngineImpl.java:826)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreate0(UiEngineImpl.java:735)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execCreate(UiEngineImpl.java:699)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execNewPage0(UiEngineImpl.java:442)
      at org.zkoss.zk.ui.impl.UiEngineImpl.execNewPage(UiEngineImpl.java:356)
      at org.zkoss.zk.ui.http.DHtmlLayoutServlet.process(DHtmlLayoutServlet.java:215)
      at org.zkoss.zk.ui.http.DHtmlLayoutServlet.doGet(DHtmlLayoutServlet.java:136)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:735)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:428)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:154)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
      at org.eclipse.jetty.server.Server.handle(Server.java:370)
      at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
      at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:971)
      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1033)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
      at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:667)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
      at java.lang.Thread.run(Thread.java:744)

      Powered by Jetty://

        Activity

        henrichen henrichen added a comment -

        1. The file contains Table record which is not supported in ZSS yet.
        2. The file contains Named range in sheet scope which is not supported in ZSS yet.

        kolodz kolodz added a comment - - edited

        Yes. But it's no a reason to crash. At least only the component should crash not all the page.

        henrichen henrichen added a comment - - edited

        Yes. I understand. I simply note down some "information" I have known here

        henrichen henrichen added a comment - - edited

        Will not crash. The root cause is that the BookImpl.getNameByName() is not correctly implemented. Still has to support "refer to caching value of external book" and "Table". Follow ZSS-711 and ZSS-712.
        3.5.0
        https://github.com/zkoss/zkspreadsheet/commit/907dbeb31af15f74c31f5550feb8a222290a80e1
        https://github.com/zkoss/zkspreadsheet/commit/c4bd7819925ffbdafc6c09c3759c4aedbe371917

        henrichen henrichen added a comment -

        Fixed.


          People

          • Assignee:
            henrichen henrichen
            Reporter:
            kolodz kolodz
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: