Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-357

if a file contains #REF! cells, it will throw a exception and can't be rendered when importing such file

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.5.0, 2.6.0, 3.0.0 RC
    • Fix Version/s: 3.0.0 RC
    • Component/s: ZSS Range & Model
    • Labels:
      None

      Description

      If a file contains #REF! cells, it will throw a exception and can't be rendered when importing such file.

      Reproducing:

      • just load attached file ref-error.xlsx

      Stack trace:

      Jun 28, 2013 3:28:03 PM org.zkoss.zss.model.sys.impl.BookHelper evaluate
      SEVERE: error evaluating formula: LOG11(10) at A1
      org.zkoss.poi.ss.formula.FormulaParseException: Unused input [(10)] after attempting to parse the formula [LOG11(10)]
      	at org.zkoss.poi.ss.formula.FormulaParser.parse(FormulaParser.java:1603)
      	at org.zkoss.poi.ss.formula.FormulaParser.parse(FormulaParser.java:194)
      	at org.zkoss.poi.xssf.usermodel.XSSFEvaluationWorkbook.getFormulaTokens(XSSFEvaluationWorkbook.java:158)
      	at org.zkoss.poi.ss.formula.WorkbookEvaluator.evaluateAny(WorkbookEvaluator.java:314)
      	at org.zkoss.poi.ss.formula.WorkbookEvaluator.evaluate(WorkbookEvaluator.java:255)
      	at org.zkoss.poi.xssf.usermodel.XSSFFormulaEvaluator.evaluateFormulaCellValue(XSSFFormulaEvaluator.java:267)
      	at org.zkoss.poi.xssf.usermodel.XSSFFormulaEvaluator.evaluate(XSSFFormulaEvaluator.java:120)
      	at org.zkoss.zss.model.sys.impl.BookHelper.evaluate(BookHelper.java:497)
      	at org.zkoss.zss.model.sys.impl.BookHelper.getFormatText(BookHelper.java:1043)
      	at org.zkoss.zss.ui.impl.XUtils.getFormatText(XUtils.java:355)
      	at org.zkoss.zss.ui.impl.CellFormatHelper.getHtmlStyle(CellFormatHelper.java:89)
      	at org.zkoss.zss.ui.Spreadsheet$ExtraCtrl.getCellAttr(Spreadsheet.java:3062)
      	at org.zkoss.zss.ui.Spreadsheet$ExtraCtrl.getRangeAttrs(Spreadsheet.java:2921)
      	at org.zkoss.zss.ui.Spreadsheet.renderProperties(Spreadsheet.java:1652)
      	at org.zkoss.zk.ui.AbstractComponent.redraw(AbstractComponent.java:1812)
      	at org.zkoss.zk.ui.AbstractComponent.redrawChildren(AbstractComponent.java:1889)
      	at org.zkoss.zk.ui.AbstractComponent.redraw(AbstractComponent.java:1831)
      	at org.zkoss.zk.ui.sys.HtmlPageRenders.outPageContent(HtmlPageRenders.java:614)
      	at org.zkoss.zul.impl.PageRenderer.renderDesktop(PageRenderer.java:104)
      	at org.zkoss.zul.impl.PageRenderer.render(PageRenderer.java:56)
      	at org.zkoss.zk.ui.impl.PageImpl.redraw(PageImpl.java:856)
      	at org.zkoss.zk.ui.impl.UiEngineImpl.execNewPage0(UiEngineImpl.java:497)
      	at org.zkoss.zk.ui.impl.UiEngineImpl.execNewPage(UiEngineImpl.java:316)
      	at org.zkoss.zk.ui.http.DHtmlLayoutServlet.process(DHtmlLayoutServlet.java:215)
      	at org.zkoss.zk.ui.http.DHtmlLayoutServlet.doGet(DHtmlLayoutServlet.java:136)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
      	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:401)
      	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
      	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
      	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:450)
      	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      	at org.mortbay.jetty.Server.handle(Server.java:326)
      	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
      	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:928)
      	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:549)
      	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
      	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
      	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410)
      	at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
      

        Activity

        dennis dennis added a comment -

        fixed since 2013/8/9


          People

          • Assignee:
            paowang paowang
            Reporter:
            paowang paowang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: