Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-355

When given start date is later than end date In NETWORKDAYS(), it returns #NAME?

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.0.0 RC
    • Fix Version/s: 3.0.0 RC
    • Component/s: ZSS Component
    • Labels:

      Description

      Problem Description:

      When given start date is later than end date In NETWORKDAYS(), it returns #NAME?. However, if this is an invalid case, it should return invalid value.

      Reproducing Steps:

      1. run Spreadsheet
      2. enter =NETWORKDAYS(DATE(2013,6,2),DATE(2013,6,1))

      Actual:
      the cell shows #NAME?.

        Activity

        hawk hawk added a comment -

        Root Cause:

        In original implementation, when start date is later than end date, it returns #NAME?. But for other unexpected cases, e.g. too many arguments, it returns #VALUE!.

        spreadsheet has different specifications from Excel:
        In Excel:
        1. 1900/1/1 (first day is Monday) is not a workday. (I don't know why, no document explains this)
        2. empty cell is treated as first day, 1900/1/1

        In Spreadsheet:
        1. 1900/1/1 is a workday because it's Monday
        2. empty cell is treated as 0

        Solution:

        Return #VALUE! when start date is later than end date which keeps consistency with other invalid cases.


          People

          • Assignee:
            hawk hawk
            Reporter:
            hawk hawk
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: