Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-354

delete the first column of merged cell and alignment of cells will be chaos

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.5.0, 2.6.0, 3.0.0 RC
    • Fix Version/s: 3.0.0 RC
    • Component/s: ZSS Component Client
    • Labels:
      None

      Description

      If user delete the first column of merged cell by selecting header, the alignment of cells will be chaos.

      reproducing steps:

      1. open the attached xlsx file: cell-border.xlsx
      2. select the column E by clicking header
      3. right click the selected header and click menu delete columns
        • the alignment of row 28 are chaos
      1. cell-border.xlsx
        9 kB
        paowang
      1. result.png
        44 kB

        Activity

        paowang paowang added a comment - - edited

        This issue will happen when two or more horizontal merged cells in one row and delete first merged cell's leftmost column.

        If there are two or more vertical merged cells in one column, the alignment won't be chaos after delet first merged cell's topmost row.
        But, the rest of first merged cell won't modify its value.
        The AU request and response both are correct, but changed value doesn't show.

        When occurring alignment chaos or cell value disappearance, switch sheet ,then everything seems correct.

        paowang paowang added a comment -

        fixed, since 2013-07-31.


          People

          • Assignee:
            paowang paowang
            Reporter:
            paowang paowang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: