Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-318

A Zsshtml project's resource file (excelStyle.css) is not included in compiled result

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.0.0 RC
    • Fix Version/s: 3.0.0 RC
    • Component/s: ZSS Component
    • Labels:

      Description

      Problem Description:

      A Zsshtml project's resource file (excelStyle.css) is not included in compiled result, because the project's structure doesn't match Maven's default structure, non-Java file will not be automatically copied to compiled result folder (target/classes)

      Reproducing Steps:

      1. compare the src/org/zkoss.zss.model/impl/html and target/classes/org/zkoss.zss.model/impl/html

      Expected:
      excelStyle.css exists in target/classes/org/zkoss.zss.model/impl/html

      Actual:
      excelStyle.css doesn't exist in target/classes/org/zkoss.zss.model/impl/html

        Activity

        hawk hawk added a comment -

        modify pom.xml to fix it.


          People

          • Assignee:
            dennis dennis
            Reporter:
            hawk hawk
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: