Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-296

"Protect Sheet" doesn't prevents cells from using auto filter

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.0.0 RC
    • Fix Version/s: 3.0.0
    • Component/s: ZSS Component
    • Labels:
      None

      Description

      Problem Description:

      According to Excel 2007's default behavior, "protect Sheet" could allow users to use auto filter, but it's not default setting. Spreadsheet allows users to auto filter.

      Reproducing Steps:

      1. display an Excel 2007 file
      2. enable a filter.
      3. click "Protect Sheet" on the tool-bar
      4. click drop-down list to change auto filter's setting

      Expected:
      drop-down list is not displayed when clicking it. (Like Excel)

      Actual:
      Some rows visibility is changed by auto filter.

        Activity

        hawk hawk added a comment - - edited

        Problem Description:

        This is specification issue. What actions are allowed when a sheet in protection.

        Root Cause:

        Original implementation doesn't forbid using drop-down filtering list.

        Solution:

        Final specification:

        Users cannot change a sheet's auto filter setting under sheet protection.

        Because it is not suitable to block event under current server-side architecture, we block sending AU at client-side.


          People

          • Assignee:
            hawk hawk
            Reporter:
            hawk hawk
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: