Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-257

unsupported charts cause spreadsheet crash.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.5.0, 3.0.0 RC
    • Fix Version/s: 3.0.0 RC
    • Component/s: ZSS Component
    • Labels:

      Description

      Problem description

      if a sheet contains unsupported charts e.g. Bubble chart or Radar chart, they will cause spreadsheet crash when displaying that sheet.

      Reproducing steps

      1. visit zss.test project's display.zul and select "chart-unsupported" sheet
        1. or use the sheet named "chart-unsupported" in attached excel file.
      2. the exception below occurs.

      Expected:
      Spec needs to be determined.

      Actual:

      嚴重的: >>java.lang.IllegalArgumentException: X Axis data source must be numeric.
      >>	at org.zkoss.poi.xssf.usermodel.charts.XSSFBubbleChartData.addSerie(XSSFBubbleChartData.java:145)
      >>	at org.zkoss.poi.xssf.usermodel.charts.XSSFBubbleChartData.<init>(XSSFBubbleChartData.java:80)
      >>	at org.zkoss.zssex.util.ChartHelper.drawXSSFChart(ChartHelper.java:617)
      >>	at org.zkoss.zssex.util.ChartHelper.drawChart(ChartHelper.java:316)
      >>	at org.zkoss.zssex.ui.widget.ChartWidget.initChart(ChartWidget.java:181)
      >>	at org.zkoss.zssex.ui.widget.ChartWidget.<init>(ChartWidget.java:58)
      >>	at org.zkoss.zssex.ui.widget.DefaultBookWidgetLoader.newChartWidget(DefaultBookWidgetLoader.java:281)
      >>	at org.zkoss.zssex.ui.widget.DefaultBookWidgetLoader.prepareChartWidgets(DefaultBookWidgetLoader.java:124)
      >>	at org.zkoss.zssex.ui.widget.DefaultBookWidgetLoader.onSheetSelected(DefaultBookWidgetLoader.java:91)
      >>	at org.zkoss.zss.ui.Spreadsheet.doSheetSelected(Spreadsheet.java:4020)
      >>	at org.zkoss.zss.ui.Spreadsheet.setSelectedSheetDirectly(Spreadsheet.java:796)
      >>	at org.zkoss.zss.ui.Spreadsheet.access$40(Spreadsheet.java:776)
      >>	at org.zkoss.zss.ui.Spreadsheet$ExtraCtrl.setSelectedSheetDirectly(Spreadsheet.java:3520)
      >>	at org.zkoss.zss.ui.au.in.SelectSheetCommand.process(SelectSheetCommand.java:87)
      >>	at org.zkoss.zss.ui.Spreadsheet.service(Spreadsheet.java:4721)
      

        Activity

        paowang paowang added a comment -

        In fact, ZSS support rendering these charts such as Bubble chart.
        But ZSS can't let user insert a new Bubble chart and Radar chart.

        paowang paowang added a comment -

        fixed, since 2013-07-05.


          People

          • Assignee:
            paowang paowang
            Reporter:
            hawk hawk
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: