Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-1093

ClassNotFoundException when loading zssjsf

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.8.0
    • Fix Version/s: 3.8.1
    • Component/s: None
    • Labels:
      None

      Description

      Start zssdemo and the exception:

      org.zkoss.zk.ui.UiException: Failed to load file: .../config.xml
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at org.zkoss.lang.Classes.newInstance(Classes.java:75)
      at org.zkoss.lang.Exceptions.wrap(Exceptions.java:205)
      at org.zkoss.zk.ui.UiException$Aide.wrap(UiException.java:56)
      at org.zkoss.zk.ui.sys.ConfigParser.parseConfigXml(ConfigParser.java:197)
      at org.zkoss.zk.ui.http.WebManager.<init>(WebManager.java:131)
      at org.zkoss.zk.ui.http.HttpSessionListener23.contextInitialized(HttpSessionListener23.java:140)
      at org.mortbay.jetty.handler.ContextHandler.startContext(ContextHandler.java:549)
      at org.mortbay.jetty.servlet.Context.startContext(Context.java:136)
      at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1282)
      at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:518)
      at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:499)
      at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
      at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:130)
      at org.mortbay.jetty.Server.doStart(Server.java:224)
      at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
      at runjettyrun.Bootstrap.main(Bootstrap.java:97)
      Caused by: java.lang.ClassNotFoundException: org.zkoss.zssjsf.Version
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at org.mortbay.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:392)
      at runjettyrun.ProjectClassLoader.loadClass(ProjectClassLoader.java:89)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Unknown Source)
      at org.zkoss.lang.Classes.forNameByThread(Classes.java:273)
      at org.zkoss.zk.ui.sys.ConfigParser.checkVersion(ConfigParser.java:126)
      at org.zkoss.zk.ui.sys.ConfigParser.checkVersion(ConfigParser.java:86)
      at org.zkoss.zk.ui.sys.ConfigParser.parseConfigXml(ConfigParser.java:176)
      ... 12 more

        Activity

        henrichen henrichen added a comment -

        Fixed.


          People

          • Assignee:
            henrichen henrichen
            Reporter:
            henrichen henrichen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: