Uploaded image for project: 'ZK Spring'
  1. ZK Spring
  2. ZKSPRING-51

Upgrading to webflow 3.1.1 or 3.2.0 and using Spring 4 - maven pulls in un-needed 3.0.4 dependencies

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.1.1, 3.2.0
    • Fix Version/s: 4.0.0
    • Component/s: None
    • Labels:
      None

      Description

      I have a dependency on Spring 4.0.6.
      When I upgraded to ZK 8 and zkspring-webflow 3.1.1 or 3.2.0, maven will pull in a ton of 3.0.4 spring dependencies which causes deployment issues with the 4.0 spring jars alongside of things. (NOTE: when using 3.1 of zkspring-webflow it would NOT pull in all the 3.0.4 jars which was good.)

      Another issue, and not sure if its related so haven't created a new ticket, but I also had issues with javassist and the error " java.lang.NoClassDefFoundError: javassist/util/proxy/Proxy Caused by: java.lang.ClassNotFoundException: javassist.util.proxy.Proxy" which I mentioned here
      http://forum.zkoss.org/question/99178/upgrading-to-zk8-javalangnoclassdeffounderror-javassistutilproxyproxy-caused-by-javalangclassnotfoundexception-javassistutilproxyproxy/

      The solution to both issues was to do a ton of excludes and to include a newer version of javassist. The related pom info had to look like the following:

      <dependency>
              <groupId>org.zkoss.zk</groupId>
              <artifactId>zkspring-core</artifactId>
              <version>3.2.0</version>
              <exclusions>
                  <exclusion>
                      <groupId>org.javassist</groupId>
                      <artifactId>javassist</artifactId>
                  </exclusion>
              </exclusions>
           </dependency>
      
          <dependency>
              <groupId>org.zkoss.zk</groupId>
              <artifactId>zkspring-webflow</artifactId>
              <version>3.2.0</version>
              <exclusions>
                  <exclusion>
                      <groupId>javax.el</groupId>
                      <artifactId>javax.el-api</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.aop</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.asm</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.beans</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.binding</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.context</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.binding</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.context.support</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.core</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.expression</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.js.resources</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.web</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.web.servlet</artifactId>
                  </exclusion>
                  <exclusion>
                      <groupId>org.springframework</groupId>
                      <artifactId>org.springframework.webflow</artifactId>
                  </exclusion>
              </exclusions>
         </dependency>
      
            <dependency>
              <groupId>javassist</groupId>
              <artifactId>javassist</artifactId>
              <version>3.9.0.GA</version>
          </dependency>
      

        Activity

        cor3000 cor3000 added a comment - - edited

        dependencies marked as optional since 4.0.0 and must be fully provided by the user


          People

          • Assignee:
            henrichen henrichen
            Reporter:
            rickcr rickcr
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: