Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4147

Comboitem icon display issue in Iceblue Compact

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.6.0
    • Fix Version/s: 8.6.1
    • Component/s: Theme
    • Labels:
      None
    • Environment:

      Iceblue Compact

      Description

      Steps to Reproduce

      https://www.zkoss.org/zksandbox/#f5
      Open the popup of the "Combobox with description and icons"

      Current Result

      The icon and text are overlapped

      Expected Result

      The icon and text are not overlapped

      Debug Information

      Redundant css in compact

      .z-comboitem-image {
      	margin-top: -4px;
      	margin-right: 4px;
      	float: left;
      	max-width: @narrowIconSize;
      	max-height: @narrowIconSize;
      
      	&:empty {
      		margin-right: 0;
      	}
      }
      

      Workaround

        Activity

        Anonymous added a comment -

        Fixed since 2018/11/30


          People

          • Assignee:
            Leon03 Leon03
            Reporter:
            rudyhuang rudyhuang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 4 hours
              4h
              Remaining:
              Time Spent - 2 hours Remaining Estimate - 2 hours
              2h
              Logged:
              Time Spent - 2 hours Remaining Estimate - 2 hours
              2h