Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4112

Listbox ROD is empty when scroll down

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 8.5.2
    • Fix Version/s: 8.6.0
    • Component/s: Browser Issue, Components
    • Labels:
    • Environment:

      IE9

      Description

      Steps to Reproduce

      <zk>
        <zscript>
          ListModelList model = new ListModelList(Collections.nCopies(250000,"item"));
        </zscript>
        
        <listbox width="200px" height="540px" model="${model}">
          <custom-attributes org.zkoss.zul.listbox.rod="true"/>
          <listhead>
           <listheader label="Load On Demand" sort="auto" />
          </listhead>
        </listbox>
      </zk>
      

      1) run the code
      2) scroll to the second half (using the scrollbar)

      Current Result

      Got a empty result

      Expected Result

      See many items

      Debug Information

      A side effect of ZK-3864
      https://github.com/zkoss/zk/blame/1cdec968f11c56d85dd6d990437c62f4d28eb0f2/zul/src/archive/web/js/zul/sel/less/listbox.less#L196

      Remove position: relative, the problem will be solved.

      Workaround

        Issue Links

          Activity

          Anonymous added a comment -

          Fixed since 2018/11/06


            People

            • Assignee:
              CharlesQiu CharlesQiu
              Reporter:
              rudyhuang rudyhuang
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 day
                1d
                Remaining:
                Remaining Estimate - 1 day
                1d
                Logged:
                Time Spent - Not Specified
                Not Specified