Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4035

Failing to set slider hflex in hlayout

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.5.2
    • Fix Version/s: 8.6.0
    • Component/s: Components
    • Labels:

      Description

      Steps to Reproduce

      Refer to the fiddle.
      http://zkfiddle.org/sample/2vsjrv3/4-bugs-for-slider-in-hlayout
      and size the window

      Current Result
      Maximum call stack size exceeded occur(in console)

      Expected Result
      resize without an error

      Debug Info
      in hlayout,
      https://github.com/zkoss/zk/blob/884e074c3ab999798dcf38b01564ec1f4c940818/zul/src/archive/web/js/zul/box/Layout.js#L261
      would cause a wrong logical result in
      https://github.com/zkoss/zk/blob/884e074c3ab999798dcf38b01564ec1f4c940818/zul/src/archive/web/js/zul/box/Layout.js#L395

      Workaround
      currently none

        Activity

        Anonymous added a comment -

        Fixed since 2018/09/14


          People

          • Assignee:
            klyvechen klyvechen
            Reporter:
            klyvechen klyvechen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 day Original Estimate - 1 day
              1d
              Remaining:
              Remaining Estimate - 1 day, 4 hours
              1d 4h
              Logged:
              Time Spent - Not Specified
              Not Specified