Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3972

java.lang.NoClassDefFoundError: org/zkoss/zk/ui/util/forEachStatus caused by import Handler

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.5.0
    • Fix Version/s: 8.5.2
    • Component/s: None
    • Labels:
      None

      Description

      The error is found in the ZK test.
      B85_ZK_3831Test and B85_ZK_3896Test can work well individually but will fail if run together.
      The reason is in ZK-3831.zul, it use <?import org.zkoss.zk.ui.util.*?> to import the package.
      And it will affect ZK-3896 EL foreach import and appear java.lang.NoClassDefFoundError: org/zkoss/zk/ui/util/forEachStatus.

        Issue Links

          Activity

          klyvechen klyvechen added a comment -

          Fixed since 2018/07/03


            People

            • Assignee:
              klyvechen klyvechen
              Reporter:
              klyvechen klyvechen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 3 days
                3d
                Remaining:
                1m
                Logged:
                Time Not Required
                Not Specified