Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3933

An onSlide event is triggered when calling LayoutRegion.setSlide(false)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Invalid
    • Affects Version/s: 8.0.2, 8.5.1.2
    • Fix Version/s: None
    • Component/s: Components
    • Labels:

      Description

      Steps to Reproduce

      http://zkfiddle.org/sample/1s71k57/1-ZK-3166-SlideEvent-not-triggered-when-setSlide-true
      Click "west toggle slide" or "east toggle slide" (Both are the same)

      When clicking the collapsed region bar (not button) / anywhere on the page, it would trigger an onSlide event.
      Using server side setSlide(false), it triggered an onSlide event.

      Current Result

      An onSlide (slide = false) event triggered

      Expected Result

      Both true and false events are not triggered. Since they are not user's interaction.
      https://www.zkoss.org/javadoc/latest/zk/org/zkoss/zk/ui/event/SlideEvent.html

      Represents an event cause by user's slidedown or slideup something at the client.

      Debug Info

      Root Cause

      ZK-3166

      Workaround

        Issue Links

          Activity

          rudyhuang rudyhuang added a comment -

          When clicking anywhere on the page (including the button), it triggers slide event on the client.
          So the event is not triggered by clicking button.


            People

            • Assignee:
              rudyhuang rudyhuang
              Reporter:
              rudyhuang rudyhuang
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour
                1h