Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3771

AFTER_PAGE_DETACHED callback doesn't work for Window component

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.0.2
    • Fix Version/s: 8.5.2
    • Component/s: Components
    • Labels:
      None
    • Environment:

      Zk CE 8.0.2.2

      Description

      Trying out the ComponentCtrl.addCallback API added at 8.0.2 and it is not working with the Window component.

      After some digging, find out that's due to the Window component has override the onPageDetached method and doesn't invoke super.onPageDetached. As a result, the AbstractComponent.onPageDetached method is never invoke for Window component. Is that by design or a bug ?

        Activity

        Anonymous added a comment -

        Fixed since 2018/04/09


          People

          • Assignee:
            klyvechen klyvechen
            Reporter:
            hengsin hengsin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 week
              1w
              Remaining:
              Remaining Estimate - 1 week
              1w
              Logged:
              Time Spent - Not Specified
              Not Specified