Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3752

browser can't download source map after reloading a page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.5.0
    • Fix Version/s: 8.6.0
    • Component/s: None
    • Labels:
      None

      Description

      Steps to Reproduce

      1. test this case with 8.5.0.FL.20170920-Eval
      2. load a simple zul like
        <zk>
           <button label="test"/>
        </zk>
        
      3. open chrome developer tool, we can see source map files
      4. reload the page again

      Current Result

      • can't see any source map in developer tool
      • server console shows errors:
        Sep 21, 2017 4:42:08 PM org.zkoss.zk.ui.http.WpdExtendlet mergeJavaScript
        WARNING: Failed to merge the source map: /js/zul.wpd
        Sep 21, 2017 4:42:08 PM org.zkoss.zk.ui.http.WpdExtendlet mergeJavaScript
        WARNING: Failed to merge the source map: /js/zul.wgt.wpd
        Sep 21, 2017 4:42:08 PM org.zkoss.zk.ui.http.WpdExtendlet$WpdContent toByteArray
        SEVERE: frozen.js not found
        Sep 21, 2017 4:42:08 PM org.zkoss.zk.ui.http.WpdExtendlet mergeJavaScript
        WARNING: Failed to merge the source map: /js/zkmax.wpd

      Expected Result

      users can see source map in developer tool

      Debug Info

        Issue Links

          Activity

          rudyhuang rudyhuang added a comment -

          Fixed since 2018/09/28


            People

            • Assignee:
              DevChu DevChu
              Reporter:
              hawk hawk
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: