Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3728

<a> renders a stacked font awesome icon with incorrect alignment

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Later
    • Resolution: Fixed
    • Affects Version/s: 8.5.0
    • Fix Version/s: 8.5.0
    • Component/s: None
    • Labels:
      None

      Description

      Steps to Reproduce

      1. load the zul below

       <a iconSclass="z-icon-square-o z-icon-stack-2x; z-icon-twitter z-icon-stack-1x"></a>
      

      Current Result

      Expected Result

      Debug Info

      Root Cause

      • caused by

      a [class^="z-icon-"],a [class*=" z-icon-"]

      { display: inline; }

      If I apply display: block, the alignment will be correct.

        Issue Links

          Activity

          rudyhuang rudyhuang added a comment -

          Fixed since 2017/09/28


            People

            • Assignee:
              DevChu DevChu
              Reporter:
              hawk hawk
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 2 hours, 30 minutes
                2h 30m