Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3723

Combobox and Bandbox ignore type="password"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.0.5
    • Fix Version/s: 8.5.0
    • Component/s: Components
    • Labels:
      None

      Description

      Steps to Reproduce

      <combobox type="password"/>
      

      Current Result

      type="password" missing on the input element

      Expected Result

      type="password" on the input element

      Debug Info

      server side Combobox extends Textbox (providing the setType() method)
      client side Combobox only inherits from InputWidget missing the implementation for setType (present at zul.inp.Textbox)

      Workaround

      add the password type via client side listener:

      passwordCombo.setWidgetListener("onBind", "this.getInputNode().type='password';");
      

        Activity

        wenninghsu wenninghsu added a comment -

        Fixed since 2017/08/31


          People

          • Assignee:
            DevChu DevChu
            Reporter:
            cor3000 cor3000
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 hour, 10 minutes
              1h 10m