Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3517

ForEach cause NoSuchElementException when using ListModel

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.0.3
    • Fix Version/s: 8.0.4
    • Component/s: None
    • Labels:
      None

      Description

      Steps to Reproduce

      run the following code (need a viewmodel)

      // a listmodel of size 5
      <forEach items="@load(vm.model_l)" step="2">
        <label value="@load(each.id)"/>
        <label value="@load(each.name)"/>
        <separator />
      </forEach>
      

      Actual Result

      NoSuchElementException occur

      Expected Result

      no exception

        Activity

        wenninghsu wenninghsu added a comment -

        Fixed since 2016/12/21


          People

          • Assignee:
            DevChu DevChu
            Reporter:
            DevChu DevChu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 4 hours
              4h