Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-2881

unexpected focus class location

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 8.0.0
    • Component/s: Components, CSS
    • Labels:
      None

      Description

      http://zkfiddle.org/sample/22t39kn/6-Focus-style

      when a item is selected then unselected, the focus(visualized with the red square in the above link) will jump back to the last selected item

      the expected behavior is the focus will stay on the unselected item, because focus should only change when a new selection is being made, either by mouse or by keyboard.

        Activity

        christopherszu christopherszu added a comment -

        fixed since 2015/09/25


          People

          • Assignee:
            christopherszu christopherszu
            Reporter:
            christopherszu christopherszu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: