Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-1962

Bad performance of Listbox after ZK 6.5.2 --> 6.5.3 upgrade

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 6.5.3
    • Fix Version/s: 6.5.4
    • Component/s: Components
    • Labels:
      None
    • Environment:

      Apache Tomcat 6 / OpenJDK 6

      Description

      Hello

      I have a Listbox with ListModelMap containing 40k objects.
      The Listbox is "paging" mold, with 100 items per page.

      Until 6.5.2, the creation and displaying of this Listbox took less than 1 second.
      After upgrading to 6.5.3, the creation and displaying of the Listbox takes 40 seconds or more (400x performance loss).
      Reverting the ZK libraries to 6.5.2 grants back the fast performance with no changes to my code.

      Here is a code snippet about how I create the Listbox...

      public class MyListbox extends Listbox {
      public MyListbox(ListitemRenderer renderer)

      { setItemRenderer(renderer); setAttribute("org.zkoss.zul.listbox.autoSort", true); setMold("paging"); setPageSize(100); setVflex(true); }

      Hope this helps to fix the bug.
      For any information you need, please ask me.

      Thanks
      Best regards
      Gianluca Bonetti

        Issue Links

          Activity

          RaymondChao RaymondChao added a comment -

          Hello Bonetti, thanks for reporting your problem. Do your have any example code to let me test. And can you tell me which zk edition are you using. CE, PE or EE? Thank you.

          gediminas gediminas added a comment - - edited

          This issue possibly affects Grid too. We also noticed performance degradation after upgrading ZK 6.5.3 PE (can't tell exactly before investigating the issue).

          Use case: Grid with paging (page size = 20) with large model (5-10k+ entries).

          prometeo prometeo added a comment -

          Hello
          I am using ZK Community Edition.

          I am building a testcase with code to reproduce the problem.
          By now I cannot reproduce in an empty project, with same conditions (Listbox with ListModelMap of 40k data, 100 item pages, sorting, ecc...)
          I am tracking down which piece of code in my main project gets up to the bug, but it will take some time.

          In the meanwhile I can tell you, that I have tried again and again to switch libraries and again, with 6.5.2 is fast, with 6.5.3 really slow.
          As soon as I can figure out which part of my code triggers the slowness bug, I will send you some test code.
          If you could investigate anyway in the changes to Listbox from 6.5.2 to 6.5.3 maybe you could find it before I could build a test case... maybe.

          Best regards
          Gianluca Bonetti

          RaymondChao RaymondChao added a comment - - edited

          This performance impact was caused by fixing ZK-1711 and had re-fixed in version 6.5.4. Please use the latest ZK version to avoid the performance issue, thanks.


            People

            • Assignee:
              RaymondChao RaymondChao
              Reporter:
              prometeo prometeo
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: