Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-1925

IE9/10 Chrome vflex issue, with invisible divs

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 6.5.3
    • Fix Version/s: 6.5.4
    • Component/s: Browser Issue
    • Labels:

      Description

      To reproduce the issue
      run the attached example IE9/10 or Chrome

      • use the buttons to add/remove the "sclass"-attribute on the red columns
        -> the height of the red columns is calculated incorrectly, if there is preceding sibling invisible by an sclass that uses "display: none", the inline style "display: none" does not cause this issue.

      in FF23/IE8 the example looks as expected, all columns consume the remaining height of a div correctly, ignoring the invisible divs.

        Issue Links

          Activity

          cor3000 cor3000 added a comment -

          current workaround is to use inline style="display: none;" attribute (instead of "sclass") then the flex size is calculated correctly

          vincentjian vincentjian added a comment -

          Bug fixed since 2013/9/9.


            People

            • Assignee:
              RaymondChao RaymondChao
              Reporter:
              cor3000 cor3000
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: