Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-1871

Comet Servlet 3 Push returns 500 Internal Server Error

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 6.5.1
    • Fix Version/s: 6.5.4
    • Component/s: General
    • Labels:
      None
    • Environment:

      ZK EE 6.5.1.1, GlassFish 3.1.2

      Description

      I have created a simple test application which does nothing more than printing "Hello World!" to the browser and registering itself to an application event queue. This leads to Comet Servlet 3 Push to be activated. When I deploy the example on GlassFish 3.1.2 and open it in the browser, some of the Comet requests return status code 200 (which is ok) and some of them return code 500 (which is not ok). Also some of the requests only take some milliseconds, some take one second and some take 30 seconds. Sometimes the requests are even canceled.

      GlassFish log does not show any exception in log file.

      1. zk-error-500.png
        75 kB

        Activity

        jumperchen jumperchen added a comment -

        I cannot reproduce the 500 error with 6.5.4.FL.20130730 version, please see the test video - http://screencast.com/t/ZHrxozyU1

        jkraushaar jkraushaar added a comment -

        I tried it again but still getting the error with Chromium Version 25.0.1364.160, Firefox 20.0 and IE 10.0.9200.16635.

        Can you provide me your extended version of the sample application? Maybe I have done something wrong.

        jumperchen jumperchen added a comment -

        Updated test files

        jkraushaar jkraushaar added a comment -

        I am getting the problems also with your example. Maybe the source of the problems is my GlassFish server instance. Which version of GlassFish are you using?

        jkraushaar jkraushaar added a comment -

        Tested again with latest and fresh installation of GlassFish 3.1.2.2. No prolems arise. Sorry for the trouble and thanks for your patience and help.


          People

          • Assignee:
            jumperchen jumperchen
            Reporter:
            jkraushaar jkraushaar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: