Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-127

Cannot open a popup/modal window including ZSS with IllegalStateException

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.5.0
    • Component/s: ZSS Component
    • Labels:
      None
    • Environment:

      Description

      Hi,

      I'd like to pop up a window including zss and try with the following zul and java code, but got an IllegalStateException. Isn't it doable?

      <window xmlns="http://www.zkoss.org/2005/zul"
              xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
              xsi:schemaLocation="http://www.zkoss.org/2005/zul http://www.zkoss.org/2005/zul/zul.xsd"
              id="spreadSheetPanel" title="スプレッドシート" closable="true"
              apply="com.diva_america.synapse.webui.SpreadSheetPanelControl"
              width="1000px" height="750px"
              onClose="spreadSheetPanel.detach()">
      
          <vlayout>
              <spreadsheet
                      id="spreadsheet"
                      src="/Users/kenjin/github/diva_lab/synapse/synapse-webui/src/main/resources/NameRange1.xlsx"
                      showSheetbar="false"
                      showToolbar="true"
                      showContextMenu="true"
                      maxRenderedCellSize="15000"
                      preloadColumnSize="32"
                      preloadRowSize="60"
                      width="1000px"
                      height="700px"
                      maxrows="50"
                      maxcolumns="120"/>
          </vlayout>
      </window>
      
          def onClick$popupSpreadSheetBtn(event :Event) {
              val panel = Executions.createComponents("/spreadSheetPanel.zul",
                  popupSpreadSheetBtn.getParent, null).asInstanceOf[Window]
              panel.doModal()
      //        panel.doPopup()
          }
      
      

      StackTrace

      [               qtp278146555-44] DefaultListableBeanFactory     DEBUG Returning cached instance of singleton bean 'org.springframework.context.annotation.internalConfigurationAnnotationProcessor'
      May 18, 2012 1:29:35 PM org.zkoss.zk.ui.impl.UiEngineImpl getResponses:1337
      SEVERE: 
      java.lang.IllegalStateException: ended
      	at org.zkoss.zk.ui.impl.UiVisualizer.getAttrRespMap(UiVisualizer.java:282)
      	at org.zkoss.zk.ui.impl.UiVisualizer.addSmartUpdate(UiVisualizer.java:237)
      	at org.zkoss.zk.ui.impl.UiEngineImpl.addSmartUpdate(UiEngineImpl.java:280)
      	at org.zkoss.zk.ui.AbstractComponent.smartUpdate(AbstractComponent.java:1487)
      	at org.zkoss.zss.ui.Spreadsheet.smartUpdate(Spreadsheet.java:4676)
      	at org.zkoss.zk.ui.AbstractComponent.smartUpdate(AbstractComponent.java:1462)
      	at org.zkoss.zss.ui.Spreadsheet.smartUpdate(Spreadsheet.java:4672)
      	at org.zkoss.zk.ui.AbstractComponent.smartUpdate(AbstractComponent.java:1527)
      	at org.zkoss.zk.ui.AbstractComponent.addEventListener(AbstractComponent.java:2039)
      	at org.zkoss.zss.ui.sys.ActionHandler.init(ActionHandler.java:612)
      	at org.zkoss.zss.ui.sys.ActionHandler.<init>(ActionHandler.java:145)
      	at org.zkoss.zss.ui.Spreadsheet$DefaultToolbarActionHandler.<init>(Spreadsheet.java:4815)
      	at org.zkoss.zss.ui.Spreadsheet.getActionHandler(Spreadsheet.java:4198)
      	at org.zkoss.zss.ui.Spreadsheet.renderProperties(Spreadsheet.java:1538)
      	at org.zkoss.zk.ui.AbstractComponent.redraw(AbstractComponent.java:1740)
      	at org.zkoss.zk.ui.AbstractComponent.redrawChildren(AbstractComponent.java:1819)
      	at org.zkoss.zk.ui.AbstractComponent.redraw(AbstractComponent.java:1759)
      	at org.zkoss.zk.ui.AbstractComponent.redrawChildren(AbstractComponent.java:1819)
      	at org.zkoss.zk.ui.AbstractComponent.redraw(AbstractComponent.java:1759)
      	at org.zkoss.zk.ui.impl.UiVisualizer.redraw(UiVisualizer.java:920)
      	at org.zkoss.zk.ui.impl.UiVisualizer.redrawComponents(UiVisualizer.java:932)
      	at org.zkoss.zk.ui.impl.UiVisualizer.addResponsesForCreatedPerSiblings(UiVisualizer.java:787)
      	at org.zkoss.zk.ui.impl.UiVisualizer.getResponses(UiVisualizer.java:647)
      	at org.zkoss.zk.ui.impl.UiEngineImpl.getResponses(UiEngineImpl.java:1332)
      	at org.zkoss.zk.ui.impl.UiEngineImpl.execUpdate(UiEngineImpl.java:1150)
      	at org.zkoss.zk.au.http.DHtmlUpdateServlet.process(DHtmlUpdateServlet.java:562)
      	at org.zkoss.zk.au.http.DHtmlUpdateServlet.doGet(DHtmlUpdateServlet.java:457)
      	at org.zkoss.zk.au.http.DHtmlUpdateServlet.doPost(DHtmlUpdateServlet.java:465)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:814)
      	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:565)
      	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:479)
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:521)
      	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:227)
      	at org.eclipse.jetty.server.handler.ContextHandler.__doHandle(ContextHandler.java:1031)
      	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java)
      	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)
      	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:186)
      	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:965)
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
      	at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
      	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
      	at org.eclipse.jetty.server.Server.handle(Server.java:349)
      	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:449)
      	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:925)
      	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:857)
      	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
      	at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:76)
      	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:609)
      	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:45)
      	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:599)
      	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:534)
      	at java.lang.Thread.run(Thread.java:680)
      

        Activity

        k2nakamura k2nakamura added a comment - - edited

        I narrowed down the cause of the problem and the stracktarce is thrown only when "showToolbar=true" is set. If I comment it out, the panel pops up as expected.

        samchuang samchuang added a comment -

        fixed since 2012/8/15

        j6er8er j6er8er added a comment -

        Where can I download a build with this fix?


          People

          • Assignee:
            Unassigned
            Reporter:
            k2nakamura k2nakamura
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: