Uploaded image for project: 'ZK Spreadsheet'
  1. ZK Spreadsheet
  2. ZSS-125

Zk Spreedsheet performances problem with an excel file generated with jexcel

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.5.0
    • Component/s: ZSS App
    • Labels:
      None
    • Environment:

      Tomcat 6.0.32 Windows Server 2008
      JExcel 2.6.12
      ZK Spr. 2.3.0

      Description

      After the show of the file in the web page, after the change of a value in one cell the browser gets busy and return this message : https://.... /zssapp/zkau/web/4e814308/js/zk.wpd:5479 is busy or don't return any, please select the option: 1) continue with the script 2) stop the running of the script.

      The problem is the same also if I delete the formulas in the two columns.

        Issue Links

          Activity

          bauern bauern added a comment -

          setShrinkToFit(true) and setWrap(true) used in Jexcel are the two functions that create the problem. Without this two methods the problem desappears.

          samchuang samchuang added a comment -

          The real cause is wrapText=true

          When a cell set wrap text, need to

          1. calculate the cell height
          2. a row need to compare each wrap text cell, find the highest cell height, and reset the row height

          Thus, when use wrap cell on each cell, will cause performance penalty

          To workaround this issue, ONLY set wrap to cell that need it, don't set wrap text to each cell.

          samchuang samchuang added a comment -

          fixed since 2012/8/21


            People

            • Assignee:
              Unassigned
              Reporter:
              bauern bauern
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: