Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4253

Horizontal custom scrollbar of Listbox covers the last item in Iceblue

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.5.0
    • Fix Version/s: 8.6.2
    • Component/s: Browser Issue, Components
    • Environment:
    • gh.sprint.customfield.default.name:
      ZK 8.6.2 S2

      Description

      Steps to Reproduce

      run attached zul
      scroll to the bottom

      Current Result

      The embedded indicator covers the last item, making it hard to read

      Expected Result

      Shouldn't cover to the last item, like Breeze

      Debug Information

      https://github.com/zkoss/zk/blob/v8.6.1/zul/src/archive/web/zul/less/norm.less#L733
      Removed and everything will be okay.

      Margin cannot be used for occupying space for body.scrollTop
      https://jsfiddle.net/wbcg803q/2/

      Workaround

      <style><![CDATA[
          .z-scrollbar-vertical-embed {
              margin-right: 0;
          }
          .z-scrollbar-horizontal-embed {
              margin-bottom: 0;
          }
          ]]>
      </style>
      
      1. listbox-scrollbar-cover.zul
        1 kB
        rudyhuang
      1. breeze.png
        7 kB
      2. screenshot-1.png
        7 kB

        Issue Links

          Activity

          rudyhuang rudyhuang added a comment -

          A regression of ZK-2305

          Anonymous added a comment -

          Fixed since 2019/05/30


            People

            • Assignee:
              rudyhuang rudyhuang
              Reporter:
              rudyhuang rudyhuang
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 day
                1d
                Remaining:
                Time Spent - 5 hours Remaining Estimate - 3 hours
                3h
                Logged:
                Time Spent - 5 hours Remaining Estimate - 3 hours
                5h

                  Agile