Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4182

zul.inp.Errorbox is shown regardless the component visibility

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 7.0.0, 8.6.0.1
    • Fix Version/s: 8.6.1
    • Component/s: Components
    • Labels:
      None
    • gh.sprint.customfield.default.name:
      ZK 8.6.1 S1

      Description

      Steps to Reproduce

      http://zkfiddle.org/sample/e0uidd/1-ZK-4144-another-issue

      1. Click "Save"
      2. The Groupbox will be opened with many error popups

      Current Result

      The last error popup is visible, but the corresponding textbox is invisible.

      Expected Result

      The last error popup should be invisible

      Debug Information

      If the groupbox is opened first, the issue doesn't happen.

      https://github.com/zkoss/zk/blob/v8.6.0.1/zk/src/archive/web/js/zk/au.js#L1498
      When a groupbox is opening, au wrongValue didn't wait for it.

      Workaround

        Activity

        Leon03 Leon03 added a comment -

        Fixed since 2019/01/14


          People

          • Assignee:
            rudyhuang rudyhuang
            Reporter:
            rudyhuang rudyhuang
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 4 hours
              4h
              Remaining:
              Time Spent - 3 hours Remaining Estimate - 1 hour
              1h
              Logged:
              Time Spent - 3 hours Remaining Estimate - 1 hour
              3h

                Agile