Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4117

Timebox using flex will cause page error on touch devices

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 8.6.1
    • Component/s: Components
    • Environment:

      Chrome simulates iPad

    • gh.sprint.customfield.default.name:
      ZK 8.6.1 S1

      Description

      Steps to Reproduce

      <zk>
      	<grid>
      		<rows>
      			<row>
      				<timebox hflex="1" />
      			</row>
      		</rows>
      	</grid>
      </zk>
      

      On mobile devices or Chrome (simulate iPad)

      Current Result

      Error code 3: ZK error, after mounting.

      Uncaught TypeError: a._scrollbar.hasVScroll is not a function
      at zjq.hasVScroll (VM692 zk.wpd:265)
      at Object.fixFlex (VM692 zk.wpd:570)
      at b.onSize (VM692 zk.wpd:569)

      Expected Result

      No error

      Debug Information

      https://github.com/zkoss/zk/blob/v8.5.2.1/zk/src/archive/web/js/zk/dom.js#L800
      This method expects a zul.Scrollbar instance.

      But not all _scrollbar is an instance of it.

      Workaround

      Avoid using flex on these components

        Activity

        Anonymous added a comment -

        Fixed since 2019/01/04


          People

          • Assignee:
            rudyhuang rudyhuang
            Reporter:
            rudyhuang rudyhuang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 4 hours
              4h
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 4 hours
              4h

                Agile