Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4102

Slider flex sizing does not update the default 200px

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 8.6.1
    • Component/s: None
    • Labels:
      None
    • gh.sprint.customfield.default.name:
      ZK 8.6.1 S1

      Description

      Steps to Reproduce

      <zk xmlns:w="http://www.zkoss.org/2005/zk/client">
      	<hlayout vflex="1" hflex="1">
      		<slider id="s1" maxpos="4" orient="vertical" slidingtext="Test"/>
      		<slider id="s2" maxpos="4" slidingtext="Test"/>
      	</hlayout>
      	<button label="s1 vflex 1" onClick='s1.setHeight(null);s1.setVflex("1")'/>
      	<button label="s2 hflex 1" onClick='s2.setWidth(null);s2.setHflex("1")'/>
      </zk>
      

      Current Result

      1. Click the 1sy button, it does not update the 1st slider's height to vflex="1".
      2. Click the 2nd button after step 1, the 1st slider's height's updated, but the 2nd slider's width does not resize to hflex="1", yet height changed to 200px.

      Expected Result

      Clicking the first button, the 1st slider should be resize to vflex="1" properly.
      Clicking the 2nd button, the 2nd slider, the width should be resize to hflex="1", and the height shouldn't be resized to 200px.

        Activity

        Leon03 Leon03 added a comment -

        Fixed since 2018/11/15


          People

          • Assignee:
            wenninghsu wenninghsu
            Reporter:
            wenninghsu wenninghsu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile