Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4099

ProxyHandler on method "set" causes error

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 8.5.1, 8.6.0
    • Fix Version/s: 8.6.1
    • Component/s: Databind 2
    • Labels:
    • gh.sprint.customfield.default.name:
      ZK 8.6.1 S1

      Description

      Steps to Reproduce

      http://zkfiddle.org/sample/33kvmq9/1-formproxy-issue
      Also found on ViewModelProxyHandler: http://zkfiddle.org/sample/3fiqket/1-viewmodelproxy-issue

      Current Result

      java.lang.StringIndexOutOfBoundsException: String index out of range: 0

      Expected Result

      No error

      Debug Information

      A side effect of ZK-3556
      toAttrName(LinkedList#set) is failed

      It needs to be checked if it is an attribute (aka JavaBean property). Method "set" is not a valid attribute and should be ignored.

      Workaround

        Issue Links

          Activity

          Leon03 Leon03 added a comment -

          Fixed since 2018/11/16


            People

            • Assignee:
              rudyhuang rudyhuang
              Reporter:
              rudyhuang rudyhuang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 4 hours
                4h
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 4 hours
                4h

                  Agile