Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 8.6.1
    • Component/s: None
    • Labels:
      None

      Description

      Steps to Reproduce

      	<slider mold="knob"
      			minpos="0.0" maxpos="100.0"
      			curpos="80" step="1" width="300px" angleArc="360"
      			style="border: 1px solid black;" strokeWidth="95"/>
      

      Actual Result

      the calculated paddings around the knob increase with the stroke width, wasting significant space with larger values.
      the paddings seem to be ~50% of the strokeWidth

      Expected Result

      constant small padding (if any)

        Activity

        cor3000 cor3000 created issue -
        cor3000 cor3000 made changes -
        Field Original Value New Value
        Attachment wasted-space.png [ 21493 ]
        cor3000 cor3000 made changes -
        Description h2. Steps to Reproduce
        {code:xml}
        <slider mold="knob"
        minpos="0.0" maxpos="100.0"
        curpos="80" step="1" width="300px" angleArc="360"
        style="border: 1px solid black;" strokeWidth="95"/>
        {code}

        h2. Actual Result
        the calculated paddings around the knob increase with the stroke width, wasting significant space with larger values.
        the paddings seem to be ~50% of the strokeWidth

        h2. Expected Result
        constant small padding (if any)
        cor3000 cor3000 made changes -
        Description h2. Steps to Reproduce
        {code:xml}
        <slider mold="knob"
        minpos="0.0" maxpos="100.0"
        curpos="80" step="1" width="300px" angleArc="360"
        style="border: 1px solid black;" strokeWidth="95"/>
        {code}

        h2. Actual Result
        the calculated paddings around the knob increase with the stroke width, wasting significant space with larger values.
        the paddings seem to be ~50% of the strokeWidth

        h2. Expected Result
        constant small padding (if any)
        h2. Steps to Reproduce
        {code:xml}
        <slider mold="knob"
        minpos="0.0" maxpos="100.0"
        curpos="80" step="1" width="300px" angleArc="360"
        style="border: 1px solid black;" strokeWidth="95"/>
        {code}

        !wasted-space.png|thumbnail!

        h2. Actual Result
        the calculated paddings around the knob increase with the stroke width, wasting significant space with larger values.
        the paddings seem to be ~50% of the strokeWidth

        h2. Expected Result
        constant small padding (if any)
        CharlesQiu CharlesQiu logged work - 16/Nov/18 6:30 AM
        • Time Spent:
          4 hours
           
          <No comment>
        wenninghsu wenninghsu made changes -
        Assignee CharlesQiu [ charlesqiu ]
        CharlesQiu CharlesQiu made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Original Estimate 2 days [ 57600 ]
        Remaining Estimate 2 days [ 57600 ]
        gh.issue.storypoints 4
        Fix Version/s 8.6.1 [ 15301 ]
        CharlesQiu CharlesQiu made changes -
        Remaining Estimate 2 days [ 57600 ] 1 day, 4 hours [ 43200 ]
        Time Spent 4 hours [ 14400 ]
        Worklog Id 17164 [ 17164 ]
        CharlesQiu CharlesQiu logged work - 19/Nov/18 3:30 AM
        • Time Spent:
          2 hours
           
          <No comment>
        Automated transition triggered when Charles Qiu created pull request #1403 in GitHub -
        Status In Progress [ 3 ] Reviewing [ 10101 ]
        CharlesQiu CharlesQiu made changes -
        Remaining Estimate 1 day, 4 hours [ 43200 ] 1 day, 2 hours [ 36000 ]
        Time Spent 4 hours [ 14400 ] 6 hours [ 21600 ]
        Worklog Id 17165 [ 17165 ]
        Leon03 Leon03 added a comment -

        Fixed since 2018/11/19

        Automated transition triggered when Leon03 merged pull request #1403 in GitHub -
        Status Reviewing [ 10101 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            CharlesQiu CharlesQiu
            Reporter:
            cor3000 cor3000
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2 days
              2d
              Remaining:
              Time Spent - 6 hours Remaining Estimate - 1 day, 2 hours
              1d 2h
              Logged:
              Time Spent - 6 hours Remaining Estimate - 1 day, 2 hours
              6h