Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-4056

InputElement select() setSelectionRange() not working in chrome

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 8.6.0
    • Component/s: None

      Description

      Steps to Reproduce

      <zk>
          <textbox id="input" value="testing"/>
          <button label="select" onClick="input.select()" />
          <button label="select testi" onClick="input.setSelectionRange(0, 5)" />
      </zk>
      

      click those buttons

      Current Result

      no text are selected after clicking those buttons

      Expected Result

      all text inside the textbox should be selected after clicking the 'select' button
      'testi' inside the textbox should be selected after clicking the 'select testi' button

        Issue Links

          Activity

          Anonymous added a comment -

          Fixed since 2018/09/20


            People

            • Assignee:
              wenninghsu wenninghsu
              Reporter:
              wenninghsu wenninghsu
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: