Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3991

Change window title not working

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: 8.5.1.2
    • Fix Version/s: None
    • Component/s: Components
    • Labels:
      None

      Description

      I've got a window which has id="windowTest". It's a popup window I open with

      Executions.createComponents("~./zul/includes/demande/windowTest.zul", null, args)
      

      In my ViewModel i've got a wire on the window

      @Wire
      Window windowTest
      

      In my AfterCompose I initialize the window title :

      void afterCompose(@ContextParam(ContextType.VIEW) Component view) {
              Selectors.wireComponents(view, this, false)
              windowTest.setTitle("test")
          }
      

      Everything works fine, the popup open with the title "test".

      I've got a button with a command and when I pushed it it does :

      @Command
      public void myCommand() {
      windowTest.setTitle("toto")
      }
      

      The title of the window is now : "tototest"....

        Activity

        Leon03 Leon03 added a comment -

        Hi,pafi
        We can't reproduce this issue. Could you please provide a sample code?

        pafi pafi added a comment -

        Hi,

        can't reproduce it now ! Really strange. You can close this issue. Sorry for the time you loss on it.


          People

          • Assignee:
            Leon03 Leon03
            Reporter:
            pafi pafi
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 day
              1d
              Remaining:
              Remaining Estimate - 1 day
              1d
              Logged:
              Time Spent - Not Specified
              Not Specified