Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3860

Chosenbox - Createable does disable Select

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 8.5.0
    • Fix Version/s: 8.6.1
    • Component/s: Components
    • Labels:
      None
    • gh.sprint.customfield.default.name:
      ZK 8.6.0 S2, ZK 8.6.1 S1

      Description

      If createable is set to true in the chosenbox:

      Try the following on your Demo-Website https://www.zkoss.org/zkdemo/combobox/chosenbox?search=chosenbox

      1. Type in to "Ada" for Adam.
      2. Select with "Key Down" Adam in the popup list and hit enter

      Expected behavior: Adam will be selected and put into the chosenbox as selected instead of "Ada"
      Actual behavior: The "Selection by key" is ignored and "Ada" is added to the chosenbox

      Btw.: The selection by mouse, does work.

        Activity

        Anonymous added a comment -

        Fixed since 2018/11/15


          People

          • Assignee:
            wenninghsu wenninghsu
            Reporter:
            x7onix x7onix
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile