Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3849

Input elements are not rendered properly in Chrome

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: 8.5.0
    • Fix Version/s: None
    • Component/s: Browser Issue
    • Labels:
      None

      Description

      https://www.zkoss.org/zk85themedemo/ has some rendering issues with input elements (like combobox) in Chrome as highlighted in attached screenshot:

      • right border is only partly visible
      • native input element and button have not same height

      I have similar issues in own zul file. Is there a workaround?

        Issue Links

          Activity

          fse fse added a comment -

          Google Chrome is up to date
          Version 63.0.3239.132 (Official Build) (64-bit)

          fse fse added a comment - - edited

          issue will be fixed by following change in theme/js/zul/inp/less/combo.less

          .z-combobox,
          .z-bandbox,
          .z-datebox,
          .z-timebox,
          .z-spinner,
          .z-doublespinner {
          &-input

          { vertical-align: top; // fixes Chrome issue }

          }

          rudyhuang rudyhuang added a comment -

          Hi fse,

          Using Chrome Version 69.0.3497.92 (Official Build) (64-bit) to browse https://www.zkoss.org/zk85themedemo/,
          I don't have these issues. They could be fixed.

          Can you re-verify and see if these issues still exist? Thanks.

          fse fse added a comment -

          Hi Rudy,

          with Chrome 69 it looks fine, while in previous version 68 issue did still exist.

          Thus, issue can be closed from my point of view.

          Thanks!

          rudyhuang rudyhuang added a comment -

          Cannot reproduce in current version of Chrome (Version 69.0.3497.92 (Official Build) (64-bit))


            People

            • Assignee:
              Unassigned
              Reporter:
              fse fse
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: