Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3820

Can't scroll a listbox horizontally and vertically in a scrollable window with a mobile browser

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 8.0.5
    • Fix Version/s: 8.5.0
    • Component/s: None
    • Labels:
      None

      Description

      Steps to Reproduce

      1. load the attached zul with chrome device emulation *iPad mini*
      2. scroll the listbox horizontally or vertically

      Current Result

      we can't scroll the listbox horizontally and vertically

      Expected Result

      Debug Info

      • the browser just scroll the window's content instead of the listbox.

      Root Cause

      • a simulated scrollbar created by iscroll
        <div id="z_1-cave2" style="transition-property: transform; transform-origin: 0px 0px 0px; transform: translate(-2px, 0px) scale(1) translateZ(0px); height: 634px; width: 758px;">
        

      Workaround

      • remove overflow:auto
      • disable iscroll (since 8.5.0)

        Issue Links

          Activity

          rudyhuang rudyhuang added a comment -

          Basically we chose disable iScroll in mobile devices by default since ZK 8.5.0 to avoid this issue.


            People

            • Assignee:
              Unassigned
              Reporter:
              hawk hawk
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: