Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3803

Timebox Issue - "TypeError: zul.Auxbutton is not a constructor"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 8.0.1, 8.5.0
    • Fix Version/s: 8.5.0
    • Component/s: Components
    • Labels:
    • Environment:

      any mobile browser, *firefox "Responsive Design Mode" *(CTRL + Shift + M) choose any device. in chrome mobile mode its working fine.

      Description

      test.zul

      <?page title="new page title" contentType="text/html;charset=UTF-8"?>
      <zk>
      <window title="new page title" border="normal">
      <timebox></timebox>
      </window>
      </zk>
      

      How to reproduce the issue

      • view the test.zul in mobile browser or
      • view the test.zul in firefox "Responsive design mode" and choose an specific device

      In the browser console it will show:
      "TypeError: zul.Auxbutton is not a constructor"

        Activity

        gglenson gglenson added a comment -

        Solution: file zul.jar

        • add the Auxbutton.js in "web/js/zul" (gotten the Auxbutton.js file from zul-6.5.0.jar).
        • modify the file zk.wpd (web/js/zul), then add this line:
            <script src="Auxbutton.js" jsdoc="true"/>
          
        • move the zul.jar to the project...
        • needs some modification with styles...
        rudyhuang rudyhuang added a comment -

        Hi gglenson,

        Auxbutton.js is removed on Jun 10, 2013. (info)
        And Timebox in mobile is no longer using it.

        I cannot reproduce this issue in ZK EE 8.5.0. Could you provide more information?

        gglenson gglenson added a comment -

        Thanks for the reply,

        I think the problem was with my project alone, since I'm just overriding my zk jars from ( 6.5 to 7 to 8.0 to 8.5).
        Probably there is a jar from old version of zk that was not remove.
        I cannot reproduce it as well when I create a new project.

        I think you could close this one now.
        Thanks again for the information and for responding.

        rudyhuang rudyhuang added a comment -

        Thanks for the reply. I'll close this issue.


          People

          • Assignee:
            Unassigned
            Reporter:
            gglenson gglenson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: