Uploaded image for project: 'ZK'
  1. ZK
  2. ZK-3712

Listbox doesn't render DOM attribute specified by client/attribute namespace

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Invalid
    • Affects Version/s: 8.0.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Steps to Reproduce

      1. load attached zul
      2. open chrome dev tool
      3. check div with z-listitem

      Current Result

      no name attribute

      Expected Result

      there should be name attribute

      Root Cause

      normal component creation invokes ComponentInfo.applyProperties() but listbox only calls AbstractComponent.applyProperties() (no client attributes included) ListboxDataLoader create listitems by its own way

        Activity

        hawk hawk added a comment -

        because of missing name on <template>


          People

          • Assignee:
            Unassigned
            Reporter:
            hawk hawk
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: